StorM - Downloads are not being provided in original quality – Incident details

Search experiencing partial outage

Downloads are not being provided in original quality

Resolved
Degraded performance
Started 8 months agoLasted 20 days

Affected

Website

Degraded performance from 5:16 PM to 11:14 AM

One-Click Download

Degraded performance from 5:16 PM to 11:14 AM

Updates
  • Resolved
    Resolved

    We have mitigated the ongoing issue by changing some configuration with our current provider. Meaning that content from now should be delivered in the quality you expect for the "original" content types.

    While the initial issue has been resolved, there are some consequences that we will continue to address;

    1) Determine a point in time that we believe the issue came about (Work in progress)

    2) Based on the point in time, attempt to re-deliver content to other systems that are affected during this period of time

    3) Continue talks on alternative options from our current provider

    4) Identify ways in which we can monitor that original files are being delivered by the provider in original formats as expected

    If there are any questions or continued support required relating to this, then you're welcome to use the "StorM" Team in Microsoft Teams to discuss. Otherwise please reach out to support via https://storm.bestseller.com/support.

  • Identified
    Update

    We still have not received any further updates relating to an ETA or fix relating to the ongoing issue at our current provider.

    Due to the length of time this unresolved issue has now taken, we have began to have talks with another provider which will continue early next week. Our initial testing indicates that this new provider could meet some of the specific requirements that StorM needs. As such, we're hopeful that our talks next week will end well.

  • Identified
    Update

    We reached out for another update, in which we received:

    "The issue with the edge rule is currently being reviewed and addressed by our dedicated team. Rest assured, we will update you with any new developments directly through this ticket."

    We'll continue to request for updates. Meanwhile we're considering alternative platforms going forward, as this level of service/communication is unacceptable.

  • Identified
    Update

    A response was received from our provider:

    "Apologies for the inconvenience. I understand the importance of your request however, we unfortunately do not have an update at the moment from our development team yet. While we do not have an ETA when this will be resolved, we'll notify you as soon as possible when we have more information to share."

    We'll continue to try escalate the problem where we can.

  • Identified
    Update

    We have not received any further communication from our provider. As such, we have reached out again for an update.

  • Identified
    Update

    We reached out again to our provider, as we have had no update regarding any news/updates from the developers there. We received the following update:

    "I am afraid that we currently do not have a solution for this and our development team is still working on a fix. We will make sure to let you know as soon as possible."

  • Identified
    Update

    We have received a not so great response still, lacking any further information:

    "Unfortunately we'd not be sure of an exact timeframe, my apologies about that. I will however chase this with our developers for you."

    We'll wait for any further update in relation an update from their developers.

  • Identified
    Update

    We have reached out to the provider for another update.

  • Identified
    Update

    A response to asking for an ETA was just received, as quoted:

    "Unfortunately, we still don't have an ETA when this will be resolved. Apologies for that."

    We'll continue to wait for any further updates today, or otherwise reach out directly again tomorrow.

    If you need to download content from StorM, then we'd advise you to download via the Basket. The Basket downloading does not rely on this 3rd party provider, and as such delivers files to you in the original upload quality.

  • Identified
    Update

    We have reached out to the 3rd party provider for an update on the situation.

  • Identified
    Identified

    We were notified of a discrepancy between images uploaded to StorM, and what was available to download (via the "One Click" download option), as well as delivered to other systems.

    After analyzing the problem, it appears a 3rd party provider that is used to deliver StorM's content (Content Delivery Network) is performing optimizations on images, even though StorM has an explicit rule defined for these optimizations to not be applied.

    An issue was raised with the provider, and they have since confirmed and identified the issue. However no ETA was provided for when this will be fixed.

    We'll update as we learn more about the siutation.